Freemius API Connectivity

FooGallery and FooBox use Freemius under the hood for updates and licensing.

Certain server hosts and WP installs sometimes block access to external websites for security reasons.

If you see an error similar to "Oops… FooBox Image Lightbox requires an access to our API" or "Oops… FooGallery requires an access to our API" then it usually means you need to whitelist access to the Freemius API.

Whitelist Access To Freemius

Kindly contact your hosting provider and ask them to whitelist wp.freemius.com and api.freemius.com for external connections.

You will then need to deactivate the plugin and activate it again to force the API connectivity check again.

Make Sure CURL Extension Installed

If the above whitelisting does not give you any success, then ask your hosting provider to make sure the CURL PHP extension is installed and working for your site.